Issues with Linode hosted services running custom PHP giving day sites on Kimbia Giving Day Platform
Incident Report for GiveGab
Resolved
After further monitoring, and a few more updates to the underlying server, issues seem to be resolved.
Posted 5 months ago. Apr 25, 2018 - 16:56 EDT
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Apr 25, 2018 - 14:12 EDT
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Apr 25, 2018 - 12:33 EDT
Monitoring
The underlying Linode server has been upgraded and emergency maintenance is complete. All sites should be resolving properly and we'll continue to monitor for issues.
Posted 5 months ago. Apr 25, 2018 - 12:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Apr 25, 2018 - 12:19 EDT
Update
We need to perform emergency maintenance on some of our Linode servers in order to rectify an issue we have been seeing.

This will result in an outage of roughly 60 minutes for several of our sites including:
1. https://supportklru.org/
2. https://givingcommon.org/

We apologize for this inconvenience and will continue to provide updates as we make progress on the emergency maintenance.
Posted 5 months ago. Apr 25, 2018 - 12:19 EDT
Identified
We are currently investigating issues across the board with our custom sites that are running on our Linode servers. Some users will continue to see sporadic Gateway 502 errors as we continue to apply a repeating reset of PHP services on the servers.
Posted 5 months ago. Apr 25, 2018 - 10:34 EDT
Update
We are seeing the issues return and are currently troubleshooting what is happening.
Posted 5 months ago. Apr 25, 2018 - 07:33 EDT
Monitoring
At 6:27 this morning, we started to see issues with a number of our custom hosted PHP giving day sites running on Linode. We were sporadically seeing these services return errors that surfaced up through our CDN as 502 bad gateways.

Impacted sites were:
Monitor is DOWN: Purdue ( https://dayofgiving.purdue.edu/ ) - Reason: HTTP 502 - Bad Gateway
Monitor is DOWN: KLRU ( https://supportklru.org/ ) - Reason: HTTP 502 - Bad Gateway
Monitor is DOWN: Giving Common ( https://givingcommon.org/ ) - Reason: HTTP 502 - Bad Gateway

After resetting the PHP service, we are seeing service return to normal but we are continuing to monitor.
Posted 5 months ago. Apr 25, 2018 - 07:02 EDT
This incident affected: Kimbia Giving Day Platform.