Brief Downtime
Incident Report for GiveGab
Resolved
This issue has been resolved.
Posted about 1 year ago. Jul 14, 2017 - 11:55 EDT
Identified
Users are experiencing 404 pages on GiveGab at the moment. Our team has identified the issue and are working through addressing it.
Posted about 1 year ago. Jul 14, 2017 - 11:41 EDT