The Giving Days platform experienced a brief outage
Incident Report for GiveGab
Resolved
At approximately 2:32PM, a mass email was sent from an outside source containing an incorrect link. The link was flagged by the email client as malicious, causing it to automatically test the link. This resulted in approximately 175k requests (13,570% above our normal rate) to the giving days app within one minute. Users experienced site-wide timeout errors causing pages not to load for two minutes while our automated systems identified the issue and recovered. We do not to expect to see any further issues from this incident.
Posted Mar 30, 2023 - 16:21 EDT
Investigating
The Giving Day platform experienced a brief outage that started at 2:32:17 PM and resolved at 02:34:17 PM. The GiveGab platform and GiveGab API were not affected. Our engineers are actively investigating the issue and continuing to monitor the situation.
Posted Mar 30, 2023 - 15:11 EDT
This incident affected: GiveGab Giving Day Platform.