Plaid (ACH) payment method temporarily unavailable
Incident Report for GiveGab
Resolved
This incident has been resolved.
Posted Jul 17, 2023 - 12:54 EDT
Identified
Plaid (ACH) payment methods are currently not available. The team has identified the issue and are currently working with the Plaid team on a fix. This issue is isolated to Plaid, and all other payment methods are functioning as expected.
Posted Jul 13, 2023 - 12:33 EDT
This incident affected: GiveGab Giving Day Platform.